Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP-FAT-type mismatch on + on CTBSERIALI(CTBXSEM.PRW)

Ocorrência
Ao efetuar a contabilização off line (CTBANFS) da nota de saída (MATA461), ocorre o erro:

type mismatch on +  on CTBSERIALI(CTBXSEM.PRW) 02/01/2020 15:42:12 line : 870


Ambiente

Microsiga Protheus - todas as versões.

Causa

O erro ocorre devido a falta de parâmetros do semáforo de contabilização no ambiente ou não criados com os tipos corretos ou não configurados:

MV_CTBSER - Tipo Numérico ---> correto Tipo Carácter com conteúdo 1, 2 ou 3;
MV_CTBNFSE - Tipo Numérico ---> correto Tipo Carácter com conteúdo 1(ligado)ou 2(desligado);
MV_CTBSERD - Tipo  Carácter ---> correto Tipo Lógico com conteúdo .T. ou .F. ;
MV_CONOUTR -Tipo Carácter--->correto Tipo Numérico  com  conteúdo 0, 1, 2 ou 3.

Solução

Para solucionar essa ocorrência, realize os seguintes passos:

1. Certificar que os parâmetros de semáforo contábil estejam criados e devidamente configurados no ambiente, caso não estejam configurar conforme as documentações da área:

MP - SIGACTB - CONFIGURAÇÃO DE SEMAFORO  

MP-SIGACTB-Type-mismatch-on-compare-on-CONOUTR?

2. Reiniciar o Smartclient e efetuar o processo de contabilização novamente.

Obs: Em caso de dúvidas sobre o funcionamento do semáforo contábil, entre em contato coma equipe de atendimento Ativo e Contábil.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _