Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

LG - FRW - Chave USERID não definida

relogio.png Tempo aproximado para leitura: 00:01:09 min

Ocorrência
Ao realizar a inicialização do serviço responsável pelo Webservice do Logix é apresentado o erro Chave USERID não definida ou usuário inválido na seção [WEBSERVICES]

Ambiente
Logix - Administração Logix - Todas as versões

Causa
Este erro ocorre durante a inicialização do Appserver responsável pelo Webservice ou durante qualquer tentativa de integração. O Sistema realiza a leitura do arquivo totvsappserver.ini para validar todas as configurações referente ao Webservice. O erro é apresentado quando não é localizado a chave USERID na sessão WEBSERVICES.

Solução
Para corrigir este problema é necessário acessar o diretório do Appserver configurado como serviço de Webservice e editar o arquivo totvsappserver.ini. Localizar a sessão [WEBSERVICES] e incluir a chave USERID. O valor da desta chave deve ser o código de um usuário administrador do Logix. Exemplo:

[WEBSERVICES]
USERID=admlog

Verificar também as variáveis de ambiente do Sistema Operacional. Caso exista a variável LOGNAME é necessário remove-la para não interferir na chave definida na sessão WEBSERVICES.


Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _