Tempo aproximado para leitura: 00:04:00 min
Ocorrência
Ao atualizar o sistema para a versão 12.1.27 ou superior, o RM não abre, utilizando instalação padrão ou Smart Client, e também não apresenta nenhum erro.
Ambiente
Framework - Linha RM - Frame - A partir da versão 12.1.27
Causa
Este incidente tem como causa a versão do Visual C++ instalada ou a falta dela, sendo necessário instalar a versão correta, para o funcionamento do sistema.
Solução
Para correção da inconsistência, siga os passos abaixo:
- Verifique se o sistema operacional possui outras versões do Visual C++ incompatíveis com o RM, pois podem afetar o correto funcionamento do sistema. Remova todas as versões que não são necessárias no ambiente para concluir a instalação. Caso faça uso de outras versões do C++ para outros aplicativos, poderá instalá-las novamente após conclusão da instalação do RM.
- Instale a versão correta do Visual C++ compatível com seu sistema operacional. Segue o link da versão correta do Visual C++ para download:
Importante: Realize a instalação da versão compatível com a sua arquitetura, 32 ou 64 bits, pois o instalador não realiza essa validação.
Após instalar o Visual C++ conforme passo anterior, verifique se o RM irá abrir corretamente.
Observação:
Caso esteja utilizando o Smart Client, verifique todos procedimentos mencionados acima e o arquivo RM.exe.config do servidor e das máquinas client. Para o correto funcionamento do Smart Client a porta configurada no UPDATESERVER, deve ser a mesma utilizada no serviço do host do servidor de atualização. Segue exemplo abaixo:
Ainda considerando que o acesso ao RM está sendo realizado via Smart Client, e as informações acima estão corretas, poderá realizar a reinstalação do RM na máquina client. Para tanto delete a pasta RM.Net, acesse o endereço via browser (http://Servidor_na_nuvem:8051/wsUpdate) realize o download e instale o RM.
Saiba mais:
Para mais informações sobre a instalação e configuração do Smart Client, acesse o link abaixo:
Configurando o Smart Client RM e TOTVS Update
0 Comentários