Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Open cursor error

time.png Tempo aproximado para leitura: 00:01:15 min

Ocorrência
Durante o uso do Datasul com banco de dados Oracle, é apresentada a mensagem de erro Open cursor error, please increase -c. (1445).

Ambiente
Framework - Framework (Linha Datasul) - Oracle – Todas as versões

Causa
O valor do parâmetro -c definido no arquivo .pf e no programa btb962aa - Cadastro de Bancos por Empresa está inferior para a execução da rotina.

Solução
Incremente o valor do parâmetro -c na conexão do banco no arquivo .pf e também no btb962aa para os bancos que necessitam de um valor maior.

Importante
Esse parâmetro deve estar definido após a conexão do Schema Holder, após o último -db e -ld,  ou no final da linha; caso contrário assume o valor default de 84. Exemplo:

-db \\servidor\\srcadger -RO -ld srcadger -db shsrcadger -ld shsrcadger -U usuario/senha@instancia -c 4000

ou

-db \\servidor\\srcadger -RO -ld srcadger -db shsrcadger -ld shsrcadger -c 4000 -U usuario/senha@instancia

O valor do parâmetro open_cursors na instância Oracle deverá ser suficiente para contemplar o valor informado no parâmetro -c para a sessão Progress

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _