Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - A value was not specified for a required property

time.png Tempo aproximado para leitura: 00:01:24 min

Ocorrência
No log do Jboss é registrado a mensagem DataDirect OpenEdge JDBC Driver A value was not specified for a required property: databaseName.

Ambiente
Framework - Framework (Linha Datasul) - JBoss - Todas as versões

Causa
Esse incidente ocorre, pois no arquivo de definições das conexões com o banco de dados existe uma linha de conexão ao banco de dados inválida.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Localize o arquivo que contenha as conexões com o seu banco de dados, progress-ds.xml, oracle-ds.xml ou sql-ds.xml, considere o correspondente ao seu banco de dados, estando este arquivo por padrão no diretório ServidorAplicacao\jboss-4.2.3.GA\server\instance-8x80\deploy\progress-ds.xml;
2. Edite o arquivo citado acima através de um editor de texto;
3. Localize todas as instruções identificadas como connection-url e valide se o servidor, porta e nome do banco dados estão corretos.

Importante
Após o ajuste realizado neste arquivo, é necessário reiniciar o serviço do seu Jboss.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _