Ocorrência
Na Gestão de Serviço, ao gerar agenda para o atendente pela Mesa Operacional apresenta erro de chave duplica na tabela TDV .
Ambiente
Prestadores de Serviços - SIGATEC - A partir da release 12.1.27.
Causa
Esse incidente ocorre, quando vão fazer a manutenção da agenda do atendente. A chave única da TDV valida a filial - TDV_FILIAL+TDV_CODABB
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse a Consulta Genérica - Consulta >> Cadastro >> Genérico;
2. Procure pela tabela TDV na filial que está apresentando o erro e valide qual é a ultima numeração do campo Cod. Agenda;
3. No Configurado (SIGACFG), acesse o Controle de Numeração (APCFG110) - Ambiente >> Cadastro >> Controle de Numeração;
4. Procure pela Tabela ABB na tabela de Próximos números;
5. Altere o numero para um valor a mais que foi apresentado na consulta genérica da tabela TDV no campo Cod. Agenda..
Ex. Se o numero no campo Cod. Agenda for 000000000012 e no Configurado estiver 000000000011, altere para 000000000013 foi alterado para um valor maior que esta sendo apresentado na tabela TDV.
Saiba mais sobre a manutenção de numeração no link abaixo:
https://tdn.totvs.com/pages/releaseview.action?pageId=235570751
0 Comentários