Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Datasul - MLF - EFD Contribuições - Bloco M: Erros e Avisos ao validar o arquivo

time.png Tempo aproximado para leitura: 00:00:40 min

Ocorrência
Erros apresentados no Bloco M do EFD Contribuições - Escrituração Fiscal Digital.

Ambiente
Cross Segmentos – TOTVS Backoffice (Linha Datasul) – Configurador Layout Fiscal (MLF) – A partir da versão 12

Causa
A geração do Bloco M no arquivo EFD Contribuições é resultado das informações geradas nos blocos A, C, D e F, ou seja é a apuração dos documentos constantes nos blocos anteriores.

Solução
O validador possui internamente várias regras de validação para apurar e comparar os dados gerados pelo contribuinte e os calculados pelo próprio.

Para fazer a apuração do Bloco M o validador leva em consideração apenas os registros dos blocos A, C, D e F que foram validados com sucesso, ou seja, não foram apresentados erros ou avisos nos registros.
Por exemplo:

  • Se existir algum erro ou aviso em um documento do bloco A esta linha do arquivo poderá não ser considerada pelo validador para compor o cálculo do bloco M.  Então, além do erro no registro do bloco A, apresentará um erro no bloco M, pois este documento não é considerado enquanto estiver inconsistente.

Desta forma se o arquivo possuir qualquer inconsistência em algum registro dos blocos A, C, D ou F, primeiramente é necessário corrigir todos os erros e avisos. Para depois realizar nova validação e verificar se é apresentado algum erro no bloco M.

Contudo, salientamos que normalmente os erros do bloco M existem por algum outro erro ou aviso em um dos blocos já citados.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _