Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP - SIGAJURI - Table does not exist ORA-00942: table or view does not exist (SISJURI)

Ocorrência

Ao acessar uma determinada rotina no Sisjuri o sistema apresenta o erro "Table does not exist ORA-00942: table or view does not exist".

Ambiente

Sisjuri –  A partir da versão 11.0;

Causa

Ao acessar alguma rotina que o usuário não tem acesso a determinada Tabela ou View no banco de dados ocorre esse incidente; 

Solução

Para solucionar essa ocorrência, é necessário liberar através do banco de dados o acesso a tabela ou view para esse usuário, aconselhamos o seguinte procedimento para descobrir a tabela ou view que esta causando o incidente.

Para localizar a tabela ou view, solicitamos que utilize um programa que rastreie informações do Oracle, utilizamos o programa "Statement Tracer for Oracle", após realizar o rastreamento verificar a ultima query feita pelo sistema, e com a ajuda do "DBA - Administrador de Banco de Dados", rodar no banco de dados com o usuário que esta ocorrendo o incidente essa query e verificar qual informações ele não possui acesso, e liberar o acesso.

1. Acessar na maquina somente o BcsCadastro com o usuário que esta com o incidente;
2. Acessar o programa OraTracer.exe, e clicar no mceclip0.png para iniciar a validação da query;
3. Realizar o procedimento para apresentar a mensagem Table does not exist ORA-00942: table or view does not exist;
4. Voltar no programa OraTracer.exe, clicar no mceclip1.png para salvar a query do procedimento;
5. Abrir o arquivo, descer até o final, e localizar a ultima query realizada pelo sistema;
6. Acessar o banco de dados, com o usuário que esta ocorrendo o incidente;
7. Rodar a query, verificar a tabela ou view que o usuário não tem o acesso;
8. Liberar o acesso a essa tabela ou view, que não será mas apresentado o incidente;

Link do Programa "Statement Tracer for Oracle"

 

 

 

 

 

 

 

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _