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Cross Segmento - TOTVS Backoffice (Linha Protheus) - ADVPL - Could not parse schema http://schemas.xmlsoap.org/wsdl/

Ocorrência
Ao realizar uma requisição SOAP com a classe TWsdlManager  e utilizando o método ParseURL, em ambiente local funciona corretamente, porém em ambiente cloud(Totvs), sempre retorna o erro abaixo:

An exception occurred ar 1:0 WsdlParser Exception: Could not parse schema http://schemas.xmlsoap.org/wsdl/ 

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) – ADVPL – A partir da versão 12

Causa
Esse incidente ocorre, pois a parametrização do ambiente está incorreta e na maioria das vezes os protocolos necessários para a requisição não estão liberados.

Solução
Para solucionar essa ocorrência, libere os protocolos TCP \ HTTP \ SOAP no ambiente cloud em questão.

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Usuários que acharam isso útil: 1 de 2

2 Comentários

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    ANDRE ELIAS DE ARAUJO

    Onde esses protocolos sao liberados? É no INI do appserver? Ou no Firewall?

    Meu ambiente estava funcionando e parou do nada.

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    MARCELO DUTRA CAMPOS

    Bom dia André!

    Essas configurações são realizada no appserver, segue documentação para auxiliar.

    https://tdn.engpro.totvs.com.br/pages/viewpage.action?pageId=185747842

     

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Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

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Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

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Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

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Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

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