Tempo aproximado para leitura:00:01:00 min
Ocorrência
Ao realizar o cancelamento de pedido na rotina 329 - Cancelar Pedido de Venda, é apresentado a mensagem: Não é possível cancelar pedido de venda! Existe o pedido de bonificação associado a este pedido.
Ambiente
TOTVS Distribuição Linha Winthor - 3 - Vendas - A partir da versão 30
Causa
Essa mensagem é apresentada pois o pedido de venda está vinculado a um pedido bonificado e o usuário não possui permissão de acesso para realizar o cancelamento.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Realize o cancelamento do pedido bonificado (TV5) na rotina 329 para em seguida cancelar o TV1.
Caso não queria cancelar o pedido bonificado:
1. Acesse a rotina 530-Permitir Acesso a Rotina
2. Informe o Usuário desejado;
3. No campo de pesquisa, informe 329;
4. Nas opções apresentadas, desmarque a permissão 16-Não permitir cancelar item/pedido com brindes vinculados e Confirme.

Com a permissão desmarcada, a rotina não validará o vínculo do TV1 com o TV5 e realizará o cancelamento do pedido normalmente.
0 Comentários