FAQs - Suporte técnico

RM - Frame - Erro ao criar: GlbActionModuleController


Ocorrência
Ao acessar o sistema RM é apresentada a seguinte mensagem de erro “Erro ao criar: GlbActionModuleController”


Ambiente
RM - Framework - A partir da versão 12.1.XX

Causa
Esse incidente pode ocorrer por três motivos aparentes:

Primeiro:  Ocorre pois o servidor está fora dos requisitos necessários de software de acordo com a Portabilidade exigida.

Segundo: Ocorre pois no momento da instalação da biblioteca RM, alguma dll foi corrompida, afetando os registros de algumas telas.

Terceiro: Inconsistência na qual a tela do License Server não era apresentada para que fosse possível alterar o endereço IP e Porta do Servidor de Licenças.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:


1. Caso o problema ocorra somente através do acesso via Smart Client:

Certifique-se de que a máquina que está realizando o acesso, se encontra dentro da nossa portabilidade para a versão do sistema utilizada:

Portabilidade


2. Caso o problema ocorra diretamente no servidor que se encontra a aplicação;

Faz-se necessário realizar a reinstalação da biblioteca RM, pois conforme já mencionado, alguma dll pode ter sido corrompida durante a instalação do sistema, impossibilitando a abertura das Actions(telas):

RM - Frame - Como realizar a reinstalação do RM

3. Avalie se o ambiente está utilizando as versões de patch abaixo ou superiores:
PATCH12.1.29.266
PATCH12.1.31.170
PATCH12.1.32.110 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

2 Comentários

  • Avatar
    Alex de sa Sousa (Editado )

    Pessoal, Colocaria uma 3ª opção  que é a verificação do IP e porta do servidor de licenças vinculado a base de dados que está com erro de acesso na aplicação RM. As vezes alterando o mesmo, ou atualizando nos parâmetros globais o acesso é regularizado.

    2
    Ações de comentário Permalink
  • Avatar
    Cleiton Speransa de Souza

    Há alguma inconsistência no processo do sistema que quando não consegue conectar-se ao license server, ao invés de abrir a tela solicitando os dados de conexão do license server o sistema retornar o erro reportado. Não é somente por falha de instalação pela falta de DLL. Testei com os últimos Patch da versão 12.1.29 e 12.1.32, e o erro é reprozido com essa mesma mensagem.

    0
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _