Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - variable does not exist AROTINA on U_MA080MNU

time.pngTempo aproximado para leitura: 00:02:00 min

Ocorrência

Ao utilizar o PE MA080MNU o sistema retorna o erro abaixo

variable does not exist AROTINA on U_MA080MNU

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) – ADVPL – A partir da versão 12.1.25

Causa
Correção na chamada do ponto MA080MNU para receber o aRotina por parâmetro e dessa forma possibilitar o cliente incluir novos menus.

Solução
Utilize o exemplo abaixo:

#INCLUDE "rwmake.ch"
#INCLUDE "Topconn.ch"
#INCLUDE "protheus.ch"
#INCLUDE "FWMVCDEF.CH"


User Function MA080MNU()

Local aRotina := ParamIxb[1]

ADD OPTION aRotina TITLE "opção adicionada 01" ACTION 'A080Manut' OPERATION 2 ACCESS 0 //"Visualizar"
ADD OPTION aRotina TITLE "opção adicionada 02" ACTION 'A080Manut' OPERATION 2 ACCESS 0 //"Visualizar"
ADD OPTION aRotina TITLE "opção adicionada 03" ACTION 'A080Manut' OPERATION 2 ACCESS 0 //"Visualizar"
ADD OPTION aRotina TITLE "opção adicionada 04" ACTION 'A080Manut' OPERATION 2 ACCESS 0 //"Visualizar"
ADD OPTION aRotina TITLE "opção adicionada 05" ACTION 'Alert("PE MA080MNU")' OPERATION 4 ACCESS 0 //"Executa Função"

Return aRotina


Saiba mais

MA080MNU

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 2

1 Comentários

  • Avatar
    Fabio Rocha

    Porque a documentação do Ponto de Entrada não foi alterada já que fizeram essa mudança. O problema não é mudar, mas sim não informar através da documentação do ponto de entrada. Criar documentações a parte não ajuda muito, pois a referência principal é a explicação do ponto de entrada.
    https://tdn.totvs.com/pages/releaseview.action?pageId=6784261

    3
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _