Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Datasul - MCE - O que é o ACT do tipo 20 e como corrigir

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao executar o programa CE0401 - Cálculo Preço Médio, ocorre a mensagem Transação de acerto - tipo 20. O item ficou com saldo em valor negativo. MAT, MOB ou GGF.

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Estoque (MCE) - Versão 12

Causa
Este acerto ocorre quando, após o cálculo do preço médio, o saldo final do item no período fica negativo em valor. Nessa situação, o Sistema gera um movimento ACT do tipo 20 com entrada em valor, quando se trata da moeda corrente. Já os movimentos ACT do tipo 21 ou 22 indicam a entrada em valor nas moedas alternativas 1 e 2, respectivamente. 


Esse acerto é registrado no último dia do período que está sendo calculado o preço médio e, posteriormente, desfeito no primeiro dia do mês seguinte. 

Solução
Realizar um movimento de entrada para suprir o saldo negativo em valor.


Este ACT - Acerto deverá ser corrigido?
Sim. Este acerto não impede a execução do cálculo do preço médio, porém impede a formação do preço médio do item no período, forçando o Sistema a valorizar o item com base no último preço médio conhecido.


Como corrigir?
Como este acerto envolve valor, basta entrar com o valor negativo em MAT, MOB ou GGF através do programa CE0220 – Transações Diversas Estoque, realizando uma DIV – Transação Diversa.


Como identificar o valor para a DIV?
Sugerimos considerar o valor do movimento ACT apresentado no programa CE0402 - Razão de Estoque, ou executar o CE0402 com o preço médio do período descalculado, a fim de verificar o saldo em valor negativo no período. Outra alternativa é utilizar o programa especial spp/cep/spce0303.r - Base de Cálculo, desde que o período esteja aberto e o preço médio já calculado, permitindo assim projetar o ajuste em valor.


Como evitar que este tipo de acerto ocorra?
Este acerto é decorrente das movimentações existentes no período e pode ocorrer devido a fatores como:

  • Looping de estrutura, onde o movimento da REQ - Requisição anula o ACA - Acabado;
  • Acertos gerados indevidamente através de DIV – Transações Diversas;
  • Entrada e saída pelo valor informado, sendo que a saída está com valor maior.

Saiba mais
Cross Segmentos - Linha Datasul - MCE - Cálculo do preço médio dos itens
Cross Segmentos - Linha Datasul - MCE - Movimentações de acerto geradas pelo cálculo do preço médio

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _