FAQs - Suporte técnico

TAF - ATUALIZAÇÃO - Possíveis problemas durante a atualização pelo instalador/atualizador

 

Ocorrência
Durante a atualização do TAF e TSS pelo instalador/atualizador, poderá ocorrer mensagens de inconsistências.

 

Ambiente
TAF - ESOCIAL, REINF - À partir da 12.1.17

 

Causa
Os incidentes poderão ocorrer em várias situações ou circunstâncias. Nesta documentação mapeamentos alguns desses problemas para ser tratado conforme dados dos arquivos de LOG's.

 

Solução
1 - Verificando os arquivos de LOG's durante o erro, acessando o diretório de instalação do TAF ou TSS e entrar na pasta bin\appserver e verificar o arquivo console.log;

 

2 - Problemas com a conexão com o banco de dados. Verificar no arquivo de log se aparece as mensagens abaixo:
"Arquivo de hashs(system/sdfhash.txt) nao existe"
"PREVIOUS ERROR : Saída no final: TOPConnect - Falha de conexão Erro -2 (MSSQL;TAF;localhost)"
"Cannot insert duplicate key row in object 'dbo.SYS_UPDATE_LOG_HEAD' with unique index"

 

3 - "Espaço em disco insuficiente":
"OCORREU UM ERRO NÃO TRATADO!: There is not enough space on the disk"

 

4 - Pastas e Subpastas dentro do diretório do TAF e TSS:
"O caminho especificado, o nome do arquivo ou ambos são muito longos":

 

5 - Erro ao transmitir os eventos do TSS para o Governo:
"Driver ACE/DBF not supported on Build x64":

 

6 - Erro ao abrir o SmartClient:
"Session ['TAF'] not found in appserver.ini ("Sessão ['TAF'] não encontrada no appserver.ini")"

 

7 - Sessão duplicada:
"Duplicate section with name 'PATCH' on line '[PATCH]' while parsing line number 0":
8 - "[ERROR][SERVER] LoadWebApp failed with error 0x000000C1:
C:\totvs\TAF\bin\appserver\webapp.dll não é um aplicativo Win32 válido."
Baixe a DLL no link abaixo:
https://suporte.totvs.com/portal/p/10098/download#detail/737320
Ao baixar a DLL, acesse a pasta appserver e substitua o arquivo de mesmo nome para o que foi baixado.
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