Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Protheus - Duvida sobre a exibição da mensagem ao alterar compartilhamento de tabela

Ocorrência
Ao alterar compartilhamento de uma tabela é exibida a mensagem:

As tabelas listadas abaixo possuem vínculo de compartilhamento com a tabela XXX e terão seu modo de compartilhamento alterado no dicionário.

A adequação da base de dados existente, caso necessária, NÃO será efetuada por esta rotina.

Caso não esteja certo desse procedimento feche a janela pressionando o botão CANCELAR.

mceclip0.png

Ambiente
MP – SIGACFG – A partir da versão 12

Causa

Esta mensagem é exibida sempre que houver uma alteração no modo de compartilhamento de uma tabela e a mesma tiver alguma relação com outra(s) tabela(s), neste caso o sistema altera também o compartilhamento da(s) tabela(s) relacionada(s) para manter a integridade dos dados e do modo de acesso do sistema a informação contida na(s) tabela(s) em questão.

Solução

Não é necessário nenhuma ação em relação ao compartilhamento da(s) tabela(s) em si, basta verifique se o novo modo de compartilhamento configurado está de acordo com os dados já existentes na(s) tabela(s) envolvidas.

Ex.: Caso o modo de compartilhamento da(s) tabela(s) seja alterado de exclusivo para compartilhado, o campo de filial deverá ficar vazio caso existam dados na(s) tabela(s) envolvida(s).

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _