FAQs - Suporte técnico

Agro - PIMS MB - MB_PORTAL - Testar String de Conexão Portal

time.png Tempo aproximado para leitura: 00:01:50 min

Ocorrência
No módulo Portal Mobilidade, ao realizar o processo é apresentada a mensagem Problema ao acessar banco Falha ao se conectar ao banco de dados, ou quando é utilizada a opção Geral e em seguida Cadastros Gerais.

TESTS.png

Na aba Configuração, onde possui as strings de conexão com as bases de dados é selecionada a opção Testar Conexão.

TESTS1.png

TESTS2.png


Ambiente

TOTVS Agro – TOTVS Agro – Bioenergia – Portal Mobilidade - MB_PORTAL – Todas as Versões

Causa
Esse incidente ocorre, pois há problemas ao acessar o banco, tendo falha ao se conectar ao banco de dados. Para que o ambiente do Portal consiga conectar-se ao Banco de Dados Oracle, é necessário que haja a instalação do Oracle Client, esta instalação fornece os recursos e as bibliotecas necessárias para que a conexão seja bem sucedida. Recomenda-se, independentemente da arquitetura do servidor, que seja utilizado o Oracle Client 32 bits, por questões de compatibilidade. Deste modo, caso o ambiente do servidor seja 64 bits, o IIS - Internet Information Services parametrizará as aplicações sites para atuar como aplicações 64 bits, gerando uma incompatibilidade com as bibliotecas do Oracle Client.

Solução
Para solucionar essa ocorrência, realize os seguintes procedimentos no servidor onde o Portal está instalado:
1. Acesse o IIS, por meio do Menu Iniciar e pesquise pela palavra IIS, deste modo, será exibido o atalho para a aplicação;
2. Selecione a opção Sites e expanda-a, para que os sites sejam exibidos;
3. Navegue até o site PortalMobile e no lado direito da tela, clique em Advanced Settings ou  Configurações Avançadas, com isto, será exibido uma tela parecida com a tela abaixo;

TESTS3.png

4. Observe que provavelmente a opção Enable 32-bit Applications estará configurada como False, gerando a incompatibilidade supracitada, deste modo, é necessário ajustar esta configuração para True assim como demonstrado a seguir;

TESTS4.png

5. Verifique após o ajuste, selecione OK e efetue uma nova tentativa de conexão com o Banco de Dados por meio do Portal Mobilidade, o resultado será conforme apresentado abaixo.

TESTS5.png

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _