Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Logística - Linha Protheus - GFE - Mensagem de erro GWF010: DB error (Insert): -37 File: GWF010 - Error : 2601 (23000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Cannot insert duplicate key row in object 'dbo.GWF010'

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
No módulo SIGAGFE - Gestão de Frete Embarcador, ao gerar um cálculo é apresentada a mensagem de erro GWF010: DB error (Insert): -37 File: GWF010 - Error : 2601 (23000) (RC=-1) - [Microsoft][SQL Server Native Client 11.0][SQL Server]Cannot insert duplicate key row in object 'dbo.GWF010' with unique index 'GWF010_UNQ'. The duplicate key value is (119, 00001077, 0).
( From tISAMFile::Write ).

Ambiente 
TOTVS Logística - TOTVS Frete Embarcador (Linha Protheus) - Gestão de Frete Embarcador (SIGAGFE) - Todas as Versões

Causa

O erro é causado por um erro na rotina GFEA084 - Frete Combinado.

Solução
A correção foi liberada na tarefa de manutenção DLOGGFE-10937. O download da correção deve ser realizado através dos links abaixo, conforme a versão do ambiente:

12.1.25 PACOTE_DE_CORRECAO_7512179_DLOGGFE-10937_12.1.25 
12.1.23 PACOTE_DE_CORRECAO_7512179_DLOGGFE-10937_12.1.23
12.1.17 PACOTE_DE_CORRECAO_7512179_DLOGGFE-10937_12.1.17  

Após a aplicação da correção, para que a replicação da tabela GWF no programa APCFG110 - Controle de Numeração seja apagada, será necessário reiniciar o serviço do License Server. 
Depois de reiniciar o License Server você ainda deve acessar o programa APCFG110, menu Miscelanea, Executar Programas, APCFG110 e confirmar se a numeração da GWF ficou corrigida. Se não corrigir, deve ajustar o número do cálculo da tabela GWF.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _