Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Linha Protheus) - ADVPL - Divergência na impressão do QRCODE

time.pngTempo aproximado para leitura: 00:03:00 min

Ocorrência

Ao utilizar a classe FWQRCode() ou método QrCode(FwMsPrinter) no Smartclient x86 na 12.1.25, a imagem gerada está incorreta.

Smartclient x86

Screenshot_15.png

Smartclient x64

Screenshot_16.png

Ambiente
Cross Segmentos - Backoffice (Linha Protheus) – ADVPL – A partir da versão 12.125

Causa
Esse incidente ocorre, pois existia uma limitação de  tamanho para geração do QRCODE nas versões anteriores. O binário mais recente contempla também a versão mais recente do printer.exe, onde foi implementado uma melhoria em relação ao QRCODE

Observação
Nas versões anteriores , não era possível a criação livre do QRCODE, onde existia um tamanho minimo aceitável para geração. Porém foi sugerido por alguns clientes a melhoria dessa funcionalidade, onde fosse possível o cliente criar o QRCODE conforme a sua necessidade, ou seja, de forma livre(sem limitação). Essa melhoria foi disponibilizado para as releases mais atuais na versão 1.7.2 do printer.exe(executável responsável pelas impressões).

Importante:
Essa melhoria visa atender uma demanda solicitada por diversos clientes, porém informamos que é de inteira responsabilidade do desenvolvedor a leitura do QRCODE, pois ao gerar uma imagem muito pequena, a mesma pode ficar corrompida e acaba comprometendo a sua leitura 


Solução
Para corrigir esse problema, baixe a versão igual ou superior a 1.7.2 do Printer.exe no portal de download TOTVS e redefina o tamanho da imagem gerada dentro de suas customizações.

Saiba mais
Implementação - Redimensionamento de QRCode e Datamatrix para dimensões inferiores ao natural.

 

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _