Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - Erro no método Post Totvs Eai CostCenter

time.pngTempo aproximado para leitura:00:01:00 min

Ocorrência
Ao fazer uma requisição "http://localhost:xxxx/REST/01/TOTVSEAI/standardmessage/v1/transactions" no TOTVS EAI, utilizando o METODO POST, é retornado o erro abaixo:

argument #0 error, expected C->O,  function XmlParser on CTBI030

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus)  – ADVPL – A partir da versão 12

Causa
Esse erro pode ocorrer pela configuração incorreta do Adapter, o não preenchimento do parâmetro MV_EAICONV, ou inconsistência nos dados enviados no "body" da requisição

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Realize as configurações conforme o Saiba Mais;
2. Verifique o parâmetro MV_EAICONV, conforme o Saiba Mais;
3. Valide o body da requisição conforme o exemplo abaixo:

METODO: POST
URLhttp://localhost:1285/REST/01/TOTVSEAI/standardmessage/v1/transactions
{
"Header" : {
"UUID" : "d6bbfa63-ca27-e2ac-0b14-101970f59a32",
"Type" : "BusinessMessage",
"SubType" : "event",
"Event" : "upsert",
"Transaction" : "CostCenter",
"Version" : "2.002",
"SourceApplication": "P122599",
"ProductName" : "PROTHEUS",
"ProductVersion" : "12.1.25",
"CompanyId" : "99",
"BranchId" : "01",
"GeneratedOn" : "2020-01-08T19:00:00-03:00",
"DeliveryType" : "sync"

},
"Content" : {
"CompanyId" : "99",
"BranchId" : "01",
"CompanyInternalId" : "99",
"Code" : "ABC005",
"InternalId" : "99|ABC005",
"RegisterSituation" : "Active",
"Name" : "Centro de Custo ABC005",
"ShortCode" : "ABC005",
"SPED" : true,
"Class" : 2
}
}

 Saiba Mais:
Configuração EAI REST
Parametro MV_EAICONV

 

 

 

 

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _