Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha RM - Frame - Memória insuficiente X Vermelho

time.png Tempo aproximado para leitura: 00:05:30 min

 

Ocorrência
Ao utilizar o RM ocorre falha na montagem da tela, apresentando X Vermelho, mensagem de memória insuficiente ou a mensagem de erro O objeto está sendo usado em outro lugar, conforme print abaixo:

 mceclip0.png

Ambiente
Framework - Linha RM - Frame - A partir da versão 12.1.2205

Causa
Esse incidente ocorre em decorrência de falta de configurações de memória virtual do Windows. 


Solução
Para solucionar essa ocorrência, realize os seguintes passos:

  1. Verifique se o ambiente está atualizado com as versões abaixo ou superior:
    12.1.2205.267, 12.1.2209.222, 12.1.2302.144 ou 12.1.2306

  2. Acesse as propriedades do Meu computador / Configurações avançadas do sistema:

    mceclip0.png

  3. Selecione a opção Avançado / Configurações:

    mceclip2.png

  4. Na tela seguinte, selecione o menu Avançado e escolha a opção Alterar de acordo com a figura abaixo:

    mceclip3.png

  5. Nesta tela é possível definir quanto de memória será alocada para executar aplicações no Windows, nesse caso deixe sempre a opção Gerenciar automaticamente o tamanho do arquivo de paginação de todas as unidades marcada, pois o Windows se encarregará de realizar essa paginação e alocar a quantidade de memória necessária para executar as aplicações.

    mceclip4.png

  6. Aumente o valor da entrada de Registro IRPStackSize. Para fazer isto, execute as seguintes etapas:
    1. Cique em Iniciar, em Executar, digite regedit e clique em OK;
    2. Localize e clique na seguinte subchave do Registro:

      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

      Se a entrada IRPStackSize não estiver nessa subchave, execute as seguintes etapas:
      • Clique em Editar, aponte para Novo e clique em Valor DWORD.
      • Digite IRPStackSize e pressione ENTER;
        Importante
        Digite IRPStackSize exatamente como aparece. O nome do valor diferencia maiúsculas de minúsculas.

    3. Clique em IRPStackSize, em Editar e em Modificar;
    4. Na caixa Dados do valor digite um valor maior e clique em OK;
      Importante
      Os valores podem ir de 0x1 a 0xC. Esses valores são equivalentes a 1 e a 12 na notação decimal.

      Se o problema persistir após a conclusão do procedimento anterior, aumente o valor de IRPStackSize.

      Importante
      O uso incorreto do Editor do Registro, ou outro método, pode causar sérios problemas, que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que os problemas resultantes do uso incorreto do Editor do Registro possam ser solucionados. A modificação do Registro é de sua responsabilidade.

              FONTE:  Erro ao acessar compartilhamentos de arquivos em um servidor configurado por SOFS: não há armazenamento de servidor suficiente disponível para processar este comando

      mceclip5.png

 Dica:

Em alguns casos é aconselhável verificar se existe algum aplicativo de segurança para acesso a Internet Banking instalado que pode estar ocasionando a inconsistência na montagem da tela ou mensagem de erro, como por exemplo, IBM Trusteer Rapport, Warsaw, etc. Caso possua, desinstale o mesmo e realize novo teste.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _