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RMS - VEN - Problemas na importação de venda erro gravação WG1FENSA

Ocorrência

No processo de importação de venda ocorre erro: Erro na Atualização da WG1FENSA ORA-01438: value larger than specified precision allowed for this column

mceclip0.png

Ambiente
RETAIL MANAGER SYSTEM - Todas versões

Causa
Criação de pedidos pelo faturamento on-line, que somados dá um total de 1 MILHÃO de CAIXAS vendidos, então estourando a quantidade..

Solução

1 - LOG DA PC_CAL_GNTA.
Na pc_cal_gnta terá a informaão do ultimo item usado antes do erro..
image.png
Na imagem acima é preciso tem a informação de que o item em questão é o 53012,e este item não contempla o dígito.
Outra informação importante no LOG da pc_cal_gnta é o modulo, e o usuário..
image.png
Ou seja, a nota é do PDV,e o módulo deveria ser do PDV e não do FAT, bem como o usuário deveria ser o usuário que está importando a venda.
Quando isso acontecer, e trazer o usuário PRODUCAO, bem como o módulo FAT.. SIGNIFICA que está acontecendo o erro na PRODUÇÃO / DESPRODUÇÃO DE RECEITA, esta é uma ETAPA da importação de venda que acontece antes de importar a venda do PDV. De forma que a importação da VENDA própria é a segunda ETAPA deste processo, que tem VÁRIAS ETAPAS..
Então este é o primeiro indício.
2 - EVIDÊNCIA DA IMPORTAÇÃO DA VENDA.
Conforme as imagens em anexo o erro aconteceu durante a importação da venda e no usuário MARCELO.
image.png
Logo, o LOG da pc_cal_gnta deveria estár com o nome MARCELO e não PRODUCAO 
image.png
Então, mais uma evidência de que o erro é porque o item em questão é um componente.
Se este item em questão é um componente significa que neste dia foi vendido a receita, e este item estava como componente desta receita.
O que atrapalhou as análises, foi que o item então tinha uma receita, mas a receita não havia sido vendida... e o perfil o item estava como UNIDADE e no erro estava como CAIXA. Ou seja, apesar do cliente ter editado o cadastro e omitir esta informação.. se o erro acontecer conforme estou citando nos pontos 1, 2 e 3 (logo a seguir) é porque precisa verificar o pedido que está formado no cliente como componentes da receita..
3 - LOG DA IMPORTAÇÃO DA VENDA.
O log em questão que está em anexo não é atual.. O qual e eu o Rodrigo tivemos acesso.. mas me recordo que no log a informação parava em ORDEM NOTAS..
Como na imagem abaixo:
image.png
OU seja, é certeza que o problema aconteceu na produção das receitas e que este item estava como componente e que a receita deste produto foi vendida. Mesmo que ao olhar a venda atual do PDV não tenha a receita vendida e ou se este item não estiver mais como componente de uma receita. Já que como vimos, o cliente pode ter alterado o cadastro, arrumado a venda a ser importada, e claro, ter esquecido de passar a informação na abertura do ticket..
Seguindo com as análises..
>  
Abrindo o FONTE da PC_RMS_PDV_IMPORTAÇÂO TEMOS A SEGUINTE INFORMAÇÂO:
image.png
Isso quer dizer que após escrever no log do PDV a informação: 
ORDEM NOTAS
É chamada a PC_CAL_PRODUCAO.ATUALIZAR_ORDEM_NOTAS.... 
Dentro deste processo existem duas consultas que serão listados os pedidos que foram gerados para a produção de receita (neste caso do cliente foi gerado pelo processo de ESTOQUE ON-LINE - PC_RMS_PDV_ONLINE )
As consultas indicarão qual é o produto que foi grava na ocasião com o perfil do cadastro errado... para obter estas consultas é somente verificar a propria pc_Cal_producao como abaixo:
image.png
A questão é como saber qual é a loja, qual é a agenda, qual é a data e qual é o pedido ??
image.png
Estas respostas estão no LOG da PC_CAL_GNTA
image.png
Com a consulta formada é possível identificar quais são os pedidos que podem estar o item que está apresentando o erro.. Então vamos para a segunda consulta..
image.png
nesta consulta é para adicionar o item que está dando erro na pc_cal_gnta..
que na ocasião é o item..
image.png
Ao filtrar o resultado no cliente foi obtido o que está sendo apresentado abaixo:
image.png
Ou seja, foi criado três pedidos pelo faturamento on-line, que somados dá um total de 1 MILHÃO de CAIXAS vendidos.  Ainda em consulta na tabela do PDV o total vendido foi 100 unidades.. Então por isso estava estourando a quantidade..
Este tipo de venda é limitada à mil e não milhão.. ou seja 999.999,999 este é o limite máximo a ser vendido pelo PDV.. pois o limite da quantidade faturada é 9.3 
Caso o cliente venda  999.999,999 X 100 (CAIXAS) não daria erro, pois, a quantidade faturada seria  999.999,999 e a quantidade em UN que é faturada x embalagem (  999.999,999 X 100 ) que daria 99.999.999,900 é 12.3
entsai_quanti_un number(12,3)
entsai_quanti_fat number(9,3) 
Quanto a solução adota..
Para resolver esta situação eu MUDEI a FLAG de 0 para 2.. que significa que a venda feita pelo estoque online já foi importada, ou seja, ela foi desconsiderada...
image.png
Então, amigos, este é um breve resumo do que foi feito no sábado das 08:00 às 14:00 analisando que estava impedindo de que a venda fosse concluída pelo PDV.
Outra evidência clara de que quando na tabela de pedidos de produção da receita foi preenchida quando o item estava com o cadastro errado é notar que o tipo de embalagem estava com CAIXA, vide imagem abaixo:
image.png
Por fim, também tem a questão da evidência do item, onde é possível notar o DUN14 do item.. a ser vendido pelo PDV como CAIXA.. ou seja, o cliente alterou as informações de venda e ainda não havia excluído a informação do DUN14 como venda à CAIXA no PDV..
image.png
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