Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Logística - Linha Protheus - GFE - Erro na criação de índice do Banco de Dados OpenEdge no ERP Protheus - Failure to acquire exclusive schema lock for DDL operation

time.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
Erro na criação de índice do Banco de Dados OpenEdge no ERP - Enterprise Resource Planning Protheus Failure to acquire exclusive schema lock for DDL operation.

Ambiente
TOTVS Logística - TOTVS Frete Embarcador (Linha Protheus) - Gestão de Frete Embarcador (SIGAGFE) - Todas as Versões

Causa
O problema é referente a criação do Banco de Dados, onde foi utilizado o Schema PUB.
O OpenEdge tenta um acesso exclusivo ao Schema para inserir o índice no catálogo de índices.
Se existem mais conexões no Banco de Dados, ele não consegue o acesso exclusivo ao catálogo e você não consegue criar o índice.
Com isso, trata-se de uma restrição operacional do Banco de Dados.

Solução
Para conseguir criar índices em tabelas com mais conexões no banco, o Schema a ser usado não pode ser o PUB.
Aconselhamos nesse caso utilizar o Schema DBO.

Segue a figura do erro em questão:

image2015-5-7_13_45_11.png

 

Importante

O banco de dados Progress - OpenEdge está homologado para ser utilizado com o módulo Gestão de Frete Embarcador até 06/2023. Consulte o documento abaixo que contém mais informações  a respeito.

Bancos de Dados Homologados.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _