FAQs - Suporte técnico

Cross Segmentos-TOTVS Backoffice (Linha Protheus)-SIGAFAT - Erro Invalid column name

Dúvida
Ao gravar um registro no sistema, gera um erro log: Invalid column name "XXXX"


Ambiente
Cross Segmentos-TOTVS Backoffice (Linha Protheus)-SIGAFAT – A partir da release 12.1.17;

 

Causa
Este incidente ocorre quando há um campo virtual de usuário na estrutura "SX3", com uso da função Posicione();

Esse tipo de erro pode ocorrer em qualquer rotina (Pedido de vendas/Liberação do Pedido/Geração de documento de saída, etc) e qualquer operação que esta rotina efetue( incluir/alterar/copiar/excluir, por exemplo). Um vez que existe o campo de usuário com a função Posicione, deve-se observar as premissas para tratar a função dentro do campo.

 

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

 

Exemplo de incidente, "Pedido de Venda" - "Invalid column name 'A1_NOME'.";   

  • Verifique como esta configurada a função posicione, caso esteja neste modelo (exemplo):
    • POSICIONE("SA1",1,XFILIAL("SA1")+M->C5_CLIENTE,"A1_NOME");
  • Realize alteração para este modelo:
    • POSICIONE("SA1",1,XFILIAL("SA1")+SC5->C5_CLIENTE,"SA1->A1_NOME")

Devido algumas alterações no DBACCESS, a equipe de tecnologia da TOTVS está verificando a nova configuração descrita acima, valide se ao alterar a configuração o erro deixa de ocorrer.

Obs: Cada Campo dentro da instrução deve ser associado ao seu devido aliás, no caso do A1_NOME, que é o campo relacionado ao erro, ele deverá ser relacionado ao seu aliás de tabela, "SA1->A1_NOME".

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _