Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Datasul - MCN - Mensagem 4.700 - Quantidade prevista deve ser maior que zero

relogio.png Tempo aproximado para leitura: 00:01:36 min

Ocorrência
No módulo de Contratos de Compra, ao cadastrar Medição se o percentual de medição for menor que 0,01 é apresentado a mensagem 4.700 - Quantidade Prevista deve ser maior que zero.

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Contratos de Compra (MCN) - Versão 12

Causa
O campo Quantidade prevista é o resultado do Limite do contrato ou item do contrato, dividido pelo Valor que está inserindo na Medição. Desta forma, o erro é apresentado quando o item do contrato ou o contrato não possuem Limite informado ou quando o Valor da medição é pequeno em relação ao Limite informado e faz com que a quantidade fique zerada.

O Sistema gera o seguinte cálculo para gerar Quantidade prevista da medição:
Perc Medição = (Valor Previsto * 100) / Limite Valor

Sendo assim:
Qtde Prevista = Perc Medição / 100

Exemplo
:
Preço unitário do item no Contrato = R$ 160.000,00
Valor informado na Medição            = 5,00
Quantidade calculada                       = 5,00 / 160.000,00 = 0,00003125

1.jpg

2.jpg

3.jpg

Neste exemplo a quantidade ficou menor de 0,01, pois irá mostrar somente 4 casas decimais após a virgula, então será apresentada mensagem 4.700 - Quantidade prevista deve ser maior que Zero!

Solução
Sendo assim é necessário avaliar a possibilidade de diminuir o limite de valor do contrato ou de aumentar o valor previsto para a medição.

Importante
Os limites do contrato são verificados através do programa CN0201 - Manutenção Contratos.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _