Ocorrência
Rejeição do Sintegra para o registro Tipo 50-Modelo inválido.
Causa
Depois que a SEFAZ criou o modelo 65 para notas fiscais de consumidores finais também foi necessário alterar a regra de validação dos arquivos Sintegra.
O problema ocorre quando há diferença entre as regras por UF e diferentes possibilidades de interpretação da regra em que, o cupom fiscal antes era gerado no registro tipo 60, mas agora ele é eletrônico e o registro tipo 50 era o indicado para documentos eletrônicos. Ainda temos um outro registro, o tipo 61, que foi criado para registrar as vendas a consumidor final que abre mais possibilidades para interpretação.
Na prática, cada UF tem uma regra para validar o Sintegra, algumas aceitam o modelo 65 no registro tipo 50, outras no tipo 61.
Solução
Para corrigir essa ocorrência, realize os passos abaixo:
1. Se você gerou seu arquivo com a opção Tipo 50 (Consumidor Modelo 65) marcado e apresentou a mensagem de erro Modelo Inválido;
2. Desmarque a opção Tipo 50 (Consumidor Modelo 65);
3. Marque a opção Tipo 61 (Vendas Consumidor Final);
4. Gere o arquivo novamente para nova validação;
5. Se o arquivo for validado sem a mensagem de erro significa que sua UF validará os documentos de modelo 65 no registro Tipo 61.
Ou
1. Se você gerou seu arquivo com a opção Tipo 50 (Consumidor Modelo 65) desmarcado e apresentou a mensagem de erro Modelo Inválido;
2. Marque a opção Tipo 50 (Consumidor Modelo 65);
3. Desmarque a opção Tipo 61 (Vendas Consumidor Final);
4. Gere o arquivo novamente para nova validação;
5. Se o arquivo for validado sem a mensagem de erro significa que sua UF validará os documentos de modelo 65 no registro Tipo 50;
6. Depois de fazer os testes passe a gerar o seu arquivo marcando a opção que validar corretamente.
Importante
Caso marque as duas opções: Tipo 50 (Consumidor Modelo 65) e Tipo 61 (Vendas Consumidor Final) apresentará duplicidade de registros.

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