Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RMS - CMP - Geração de título Contas a Receber após fechamento de pedido


Ocorrência
Ao realizar o cancelamento / fechamento parcial de pedido (VGCMCPED) que tem como condição de pagamento 999 (bonificação), não está gerando titulo no contas a receber após a integração.
Isto seria um problema?

Ambiente
Retail Manager System – CMP – Todas as versões

Causa
Para ser gerado título no Contas a Receber, cancelando o pedido por inteiro, apenas cancelando itens, não será gerado registro.

Solução
O fechamento deve ser realizado diariamente, e de acordo tolerância cadastrada, o pedido será fechado após fechamento da carteira de pedidos.

Como forma de consultar os itens cancelados, a consulta abaixo, permite trazer os itens cancelados de pedidos ainda abertos:

SELECT FOR_DETF||DAC(FOR_DETF)       AS FORNECEDOR,
      CODLOJ_DETF||DAC(CODLOJ_DETF) AS LOJA,
      NROPED_DETF||DIGPED_DETF      AS PEDIDO,
      ITM_DETF||DIG_DETF            AS ITEM
FROM AG1LPEDI, AG1FDPED
WHERE COND_PAG_CAR            > 997
 AND RMS6TO_RMS7(DTAFIM_CAR) > 1190607 --AAAMMDD (ano mês dia em formato RMS7)
 AND CODLOJ_DETF             = CLOJ_CAR
 AND NROPED_DETF             = NROPED_CAR
 AND DIGPED_DETF             = DIGPED_CAR
 AND FOR_DETF                = CODFOR_CAR
 AND STATUS_DETF             = 4;


De acordo a consulta, observar ainda o seguinte ponto, pois:
Pode ocorrer registros na base, que detenham um mesmo número de pedido pra uma mesma origem, mesmo destino e mesmo item, é difícil, mas não impossível, contudo é preciso analisar com atenção esta situação, caso ocorra.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _