Ocorrência
Não é possível realizar a baixa do ressuprimento. Aparece uma mensagem informando que o endereço está indisponível, programa VGDRESPI.
Ambiente
Retail Manager System – Distribuição – Todas as versões
Causa
Essa situação ocorre quando é gerada uma atividade de ressuprimento, porém antes desta atividade ser baixada, algum usuário efetua um ajuste no endereço, o qual pode ser feito pelo módulo de Consultas no WMSMobile ou em uma auditoria de endereço, no Programa Auditoria de Endereços (VGDMMENU).
Solução
Desta forma, é possível que não exista mais o mesmo produto alocado no endereço para o qual havia sido aberta a atividade de ressuprimento. Neste caso, é necessário solicitar um pacote de atualização do WMSMobile com o módulo de Consultas e os programas referente a Auditoria de Endereços do WMS, pois já foi criado um bloqueio nesses programas. Nenhum ajuste pode ser realizado em um endereço que exista alguma atividade de ressuprimento pendente, é necessário antes realizar a baixa da atividade para prosseguir com qualquer ajuste.
Caso seja necessário fechar os ressuprimento 'manualmente', faz-se necessário alterar status do ressuprimento na tabela correspondente, AA3REPIC, de acordo exemplo a seguir:
Para fechar os ressuprimentos abertos do depósito 9016, com data inferior a 28/03/2018 no galpão 9, será preciso realizar o script:
UPDATE AA3REPIC SET REPP_SITUACAO = ('F')
WHERE REPP_DEPOSITO = 9016
AND REPP_DATA_ALT2 <= 1180328
AND REPP_SITUACAO NOT IN ('F')
AND REPP_GALPAO_ORG = 9
0 Comentários