Tempo aproximado para leitura: 00:01:20 min
Ocorrência
Quando o Contas a Pagar não recebe no retorno escritural a mesma chave do envio escritural é apresentada a mensagem de erro 8186 - A chave informada no arquivo não atende ao formato padrão Datasul.
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Contas a Pagar (APB) - Versão 12
Causa
Quando o Contas a Pagar não recebe no retorno escritural a mesma chave do envio escritural, é apresentada a mensagem de erro 8186 - A chave informada no arquivo não atende ao formato padrão Datasul, ocorre no momento do envio do pagamento escritural ao EDI - Electronic Data Interchange, pois não foi gerada a chave correta no arquivo de envio, ou o banco não está retornando a chave que foi enviada inicialmente, e também pode ter como causa, a geração na sequência incorreta no arquivo de retorno.
Para melhor entendimento do processo, no envio do pagamento escritural, o Contas a Pagar envia para o EDI o Seu Número formato (XXXXX;999999999;N; ou XXXXX;999999999;Y;) através do mapa de Extração, e este mesmo número e formato deve ser validado no arquivo de retorno e sequência que são esperadas pelo EDI.
|
Seq
|
Elemento
|
Label
|
Formato
|
Tam
|
Origem no Módulo
|
Comentário Técnico
|
|---|---|---|---|---|---|---|
| 21 | 3928 | Seu Número | x(25) | 25 |
Identificador do Título no Sistema:
Estabelecimento do Item do Borderô;Id do Item do Borderô;N;
ou
Estabelecimento dos Itens do Borderô Agrupados;Id dos Itens do Borderô Agrupados;Y;
|
item_bord_ap.cod_estab_bord + ";" + item_bord_ap.num_id_item_bord_ap + ";" + 'N' + ";"
ou
item_bord_ap_agrup.cod_estab_bord + ';' + item_bord_ap_agrup.num_id_agrup_item_bord_ap + ';' + 'Y' + ';' |
Solução
Para sanar a inconsistência, é necessário avaliar qual a causa efetiva do erro, seguindo os passos abaixo:
1. A chave deverá ser gerada no arquivo que é enviado ao banco pelo mapa de Exportação parametrizado no EDI, e para verificar qual a informação gerada, é necessário emitir o Relatório de Dados de Entrada\Saída - prgint/edu/edu327aa.r informando o processo do Envio e marcando no campo Layout a opção Saída. No relatório gerado procurar por ;N; ou ;Y; no segmento Detalhe, ou, abrir o arquivo de envio e procurar por ;N; ou ;Y;:

Se o problema foi identificado no passo 1, ou seja, não foi gerada a chave correta no arquivo de envio, então não há muito o que fazer se o banco já processou a baixa, pois como a chave não foi enviada não será possível encontrar no Sistema os títulos para serem baixados no retorno escritural. Neste caso deve ser feita a baixa manual dos itens do borderô através do programa de Confirmação de Borderô - prgfin/apb/apb716aa.r.
2. O banco deve mandar esta mesma informação no arquivo de retorno, então deve-se abrir o arquivo de retorno em um editor de texto e procure por ;N; ou ;Y;:

E se o problema está no passo 2, ou seja, o banco não está enviando no arquivo de retorno a mesma chave que foi enviada no arquivo de envio, deve-se entrar em contato com o banco para verificação.
3. Esta mesma chave deve ser importada do arquivo corretamente pelo mapa de Importação parametrizado no EDI. E para verificar esta situação, é necessário emitir o Relatório de Dados de Entrada\Saída - prgint/edu/edu327aa.r informando o processo do Retorno e marcando no campo Layout a opção Entrada. No relatório gerado procurar por ;N; ou ;Y; no segmento Detalhe:

4. O EDI deve retornar esta mesma chave para o Contas a Pagar através do mapa de Efetivação. E para avaliar, deve-se então, emitir o Relatório de Dados de Entrada\Saída - prgint/edu/edu327aa.r, informando o processo do Retorno e marcando no campo Layout e a opção Saída. No relatório gerado procurar pela sequência 9 do segmento Detalhe:

Desta forma, se o problema está no passo 3 ou 4, ou seja, a chave existe no arquivo de retorno mas não está sendo enviada na sequência 9 do mapa de Efetivação do EDI para o Contas a Pagar, deve ser ajustado o mapa de importação no módulo de EDI.
Em últimos casos também pode ser feita a confirmação manual dos itens através do programa de Confirmação de Borderô - prgfin/apb/apb716aa.r.
Importante
No Contas a Pagar não há como saber qual é o número do processo do envio ou do retorno escritural, esta informação consta somente no EDI, a dica é procurar o processo no EDI através da data do envio ou retorno ou arquivo que foi gerado.
O erro também pode ocorrer se:
- Entre o envio e o retorno o borderô foi estornado e refeito.
- O envio não foi feito pela base de dados que está sendo feito o retorno.
0 Comentários