FAQs - Suporte técnico

Cross Segmentos - TOTVS Backoffice (Linha Protheus) - SIGAPMS - array out of bounds ( 0 of 35 ) on A203GD1LINOK(PMSA203.PRW)

Ocorrência

Ao alterar a estrutura do projeto é gerado o error.log :

array out of bounds ( 0 of 35 ) on A203GD1LINOK(PMSA203.PRW) 01/03/2019 15:11:05 line : 1297


Ambiente

Cross Segmentos-TOTVS Backoffice (Linha Protheus)-SIGAPMS - todas as versões.

Causa

O erro de array out of bounds significa que um campo dentro do array não existe no banco/sx3 ou está com o uso desmarcado ou teve mudança do nível de campo.

Neste caso , pode ser que os campos AFA_OPC e AFA_MOPC que fazem parte do array, possam não estar marcados como usado ou o nível de campo foi mudado do valor padrão.

Solução

Para solucionar essa ocorrência, realize os seguintes passos:
1. Acessar o Configurador, base de dados, dicionário de dados, selecionar a tabela AFA e edite;
2. Deixe os campos AFA_OPC e AFA_MOPC marcados como usado e com o nível igual a 1;
3. Salve a tabela AFA, atualize o dicionário de dados, reinicie o smartclient e refaça o processo.

Obs: Por padrão de sistema, o campo AFA_MOPC não pode ter o nível alterado, ele requerido na validação da getdados pela função A203GD1LinOk com o nível 1.

Caso precise efetuar alguma validação de linha junto ao usuário, para digitação diretamente no campo, utilize o ponto de entrada de validação de linha A203LINOK1

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _