Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RMS - CMP - Produtos que não aparecem na sugestão do Compras Filiais



Ocorrência
Ao realizar a sugestão de compras na tela de Compras Filial, alguns itens não estão sendo mostrados, porém isso só ocorre para alguns usuários do RMS, para outros usuários, todos os itens são carregados.

mceclip0.png
Ambiente
Retail Manager System – Compras – Todas as versões - Produção

Causa
Problema ocorre devido a presença do mesmo registro (itens) na tabela temporária da sugestão do compras filial AG4SPEDL. Caso tenha presença de 'sujeira' na referida tabela, ou seja, a presença do registro itens de acordo a sugestões antigas, ao ser realizada uma nova sugestão, os itens que já detiverem registro na tabela, não irão retornar na consulta.

Solução
1. Verificar se existem registros na tabela AG4SPEDL. Pois visto ser uma tabela temporária, se no momento em que for consultada, não tiver sendo realizada nenhuma sugestão, a mesma deverá está vazia.

2. Caso tenha presença de registros antigos (sujeira), e estes itens não retornarem na sugestão, para determinado usuário na tabela, faz-se necessário sua limpeza.

3. O script a seguir servirá para limpar dados inconsistentes da tabela AG4SPEDL, de acordo usuário RMS que apresente problemas ao gerar sugestão com itens faltantes:
DELETE FROM AG4SPEDL WHERE MOV_USUARIO_P = nomeUsuario

4. NOTA: 
A questão do sistema não retornar itens e não apresentar nenhuma mensagem de erro, é pelo fato de que, se algum comprador tiver gerando uma sugestão, e posteriormente, gerar uma nova sugestão para os mesmos itens, como já foi realizada uma sugestão anterior, ele não precisa ficar lembrando se gerou ou não, sugestão pra tal item, e desta forma, não irá retornar o item em tela, evitando duplicidades, de sugestões, pedidos, ou excesso de abastecimento.

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _