Ocorrência
Venda não processa para o Gerencial, como se o Job estivesse travado.
Ambiente
Retail Manager System – Gerencial– Todas as versões
Causa
O problema eram as SEQUÊNCIAS de banco do gerencial que estava com tamanho pequeno.
NOME DA SEQUÊNCIA: SEQ_LOG_GER e SEQ_
Solução
Abaixo um passo a passo de como verificar se a sequência SEQ_LOG_GER está errada, segue:
1. A mesma precisa estar com o ciclo como Y e MAX_VALUE como 99999999999999, e no cliente estava com ciclo N e MAX_VALUE como 9999999;
5. Procurar a sequência SEQ_LOG_GER e clicar com o botão direito e ir em PROPRIEDADES;
6. Em propriedades olhar o valor máximo e o ciclo (MAX_VALUE);
7. Para a sequencia SEQ_LOG_ATU_GER é preciso olhar o valor máximo, e o ciclo pode estar com N;
Outra coisa que pode acontecer e que também não integra o GERENCIAL , fora os problemas mais comuns que são durante a importação de venda e jobs.. Além da sequência é o custo de reposição que pode estar errado..
Então é também indicado que seja verificado o custo de reposição, se ele estiver muito alto está errado, para tal, segue os processos abaixo:
Executar o select abaixo e verificar se traz algum produto
SELECT * FROM AA3CITEM
WHERE GIT_CUS_REP > 99999999999;
Se trouxer com valor maior, efetuar select também na AGG_ESTQ_PROD, informando o código do produto
Se trouxer com valor maior, efetuar select também na AGG_ESTQ_PROD, informando o código do produto:
SELECT * FROM AGG_ESTQ_PROD
WHERE CD_PROD = --Código Produto sem digito
AND ID_DT > --Pode ser o ID_DT de 01 de janeiro do ano corrente
Para ter o ID é preciso efetuar a consulta abaixo mudando apenas o ano, que no exemplo está 2019.
Select * from dim_per
where dt_compl = to_date('01/01/19', 'DD/MM/YY')
Se retornar valor, pedir ao cliente para efetuar nova tabela de fornecedor corrigindo o Custo, corrigir na base a AGG_ESTQ_PROD e depois reprocessar o Gerencial.
0 Comentários