Ocorrência
Cliente entrou em contato informando que está dando erro durante a importação dos cupons 60I, programa VGTIFCIT, versão 12.18.1.

Ticket - 7287763
Ambiente
Retail Manager System – Tesouraria – Todas as versões.
Causa
Geralmente este erro ocorre quando as tabelas do 60i não foram convertidas.
Ideal o cliente converter as tabelas fiscais (fr60i).
As procedures de conversão tem que estar atualizadas (PROC_TES_MOVI e PROC_TES_CUP_CONV).
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Rodar o script CNV_F60I.SQL de conversão na base do cliente no ambiente que apresenta o erro apenas dos clientes R23 e R18;
2. Acessar o Banco de Dados PL/SQL;
3. Selecione FILE - NEW - COMMAND WINDOW;
4. Coloque no campo SQL> o caminho que está salvo o arquivo CNV_F60I.SQL;

5. Aparacerá uma mensagem para informar periodo inicial e final no formato DDMMAAA;

6. Após a conversão, certificar que os programas VCTUR60I e as procedures PROC_TES_MOVI estão atualizadas., e realizar o processo de importação;
7. Verificar no banco de dados se nas tabelas AA1FR60I e na tabela AG3VNFCC estão com os campos no DESCRIBE conforme imagem abaixo;

8. Fazer em uma tabela por vez, clicando no botão direito do mouse em cima do nome da tabela AA1FRE60I em seguida AG3VNFCC;

9. Campos da tabela NFCC_INF_CHR e R60IVLR_ACR e R60I_CHV_CEL (chave do cupom eletronico).
0 Comentários