FAQs - Suporte técnico

DS - BA - Carga GD: erro no Agent, extração do banco de dados

time.png Tempo aproximado para leitura: 00:01:00min

Ocorrência
Na execução da carga pelo Agent ocorre o seguinte erro no log: Erro na extração do banco de dados. Erro: %s [Ljava.lang.String;@xxxxxxxx

Ambiente
Datasul – GoodData e Cognos – Todas as versões

Causa
O erro ocorre na tentativa de conexão do Agent com o banco temporário - emsinc, usando as configurações JDBC - Java Database Connectivity no my.properties

Solução
Deve ser analisado se as informações do path e drive estão corretas, exemplo:

jdbc.driver_path=C:/dlc102b/java/OPENEDGE.jar
jdbc.driver=com.ddtek.jdbc.openedge.OpenEdgeDriver

Assim como as informações de conexão url, user e senha, exemplo:

jdbc.url=jdbc:datadirect:openedge://10.80.128.223:23639;databaseName=emsinc;defaultSchema=pub
jdbc.username=pub
jdbc.password=pub

É necessário que a porta utilizada seja do broker do banco emsinc.

image2017-8-1_8_32_1.png

Sugerimos que utilize o usuário e senha pub.

Você pode confirmar sua criação no _admin.r pelo Executar Programa no ERP - Enterprise Resource Planning.

Selecionando o banco - emsinc

image2017-5-23_15_9_13.png

Lista de usuários:

image2017-5-23_15_15_25.png

Criando usuário:

image2017-5-23_15_11_32.png

Caso o problema persista, faça uma conexão ODBC - Open Database Connectivity com o banco para verificar erro em tela.

image2017-5-23_15_22_23.png

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _