Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - Erro ao excluir cadastro de funcionário


time.png
Tempo aproximado para leitura: 00:04:15 min

Ocorrência
Ao tentar excluir o cadastro de funcionário, são apresentadas mensagens que reportam erro ao excluir registros de tabelas como PFUNC, APARFUN, entre outras. Segue abaixo alguns exemplos de erros que podem ser apresentados:

Erro ao excluir os registros da tabela PFUNC.
Verifique as tabelas relacionadas.
FKPFITEMLAN_PFUNC

Erro ao excluir os registros da tabela PFUNC.
Verifique as tabelas relacionadas.
FKVCONSULTASPRONT_PFUNC

Erro ao excluir os registros da tabela PFUNC.
Verifique as tabelas relacionadas.
FKPPFUNCPRESTSERVTERCEIROS_PFU

Erro ao excluir os registros da tabela PFUNC.
Verifique as tabelas relacionadas.
FKPGPSLOGCALCDETALHE_PFUNC

Erro ao excluir os registros da tabela APARFUN.
Verifique as tabelas relacionadas.
FKAPERFUN_APARFUN

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - Todas as versões

Causa
Este tipo de incidente ocorre pois, após o cadastro do funcionário, houveram movimentações para o funcionário, como lançamento de folha, recálculos, lançamentos de certas informações que alimentam tabelas do módulo de Folha de Pagamento, bem como de outros módulos, como: Automação de Ponto, Gestão Financeira, etc.

Solução
A rotina exclusão de funcionário foi criada para excluir um funcionário somente quando for criado no mês de competência atual e não ter tido nenhuma movimentação ou processo executado para o mesmo. Porém caso o usuário já tenha realizado qualquer movimentação para esse funcionário, será apresentado erro ao executar a rotina de exclusão. Na mensagem, será apresentado qual foi a tabela envolvida, portanto, será necessário acionar o DBA da própria empresa para realizar a limpeza via Banco de Dados nas tabelas apresentadas. Essa intervenção via Banco de Dados é de responsabilidade da própria empresa. O erro na exclusão do funcionário é uma segurança do produto, pois foi detectado a execução de processos para o funcionário, não permitindo a exclusão.

Importante
Caso seja de preferência da empresa, também temos o setor de Consultoria tarifada. Neste serviço, um Consultor TOTVS poderá realizar os procedimentos necessários diretamente na Base de Dados do cliente.

Saiba mais
TOTVS RH - Linha RM - PTO - Como realizar a exclusão de funcionários admitidos no período atual
RH - RM - FOP - Exclusão de funcionário

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _