Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Linha RM - PAT - Erro ao usar funcionários rm labore como responsáveis

time.png Tempo aproximado para leitura: 00:04:12 min

Ocorrência

No módulo Gestão Patrimonial ao marcar o parâmetro "Usar funcionários RM Labore como responsáveis"
é apresentada a seguinte mensagem:
ORA-01779: não é possível modificar uma coluna que mapeie uma tabela não preservada pela chave. System.Exception: update ibem set recmodifiedby = 'mestre', recmodifiedon = sysdate, codrespatual = null, datarespatual = null where codcoligada = 1 and codrespatual is not null. End of inner exception stack trace.
at RM.Lib.Data.DbServices.QueryExec.(String sql Text, Object [] parameters)
at RM.Pat.Parametros.PatParamData.ConsistePFunc(String codUsuario).

Ambiente

Cross Segmentos - Backoffice Linha RM - TOTVS Gestão Patrimonial - A partir da versão 12.1

Causa
A mensagem é apresentada devido a empresa já conter vários responsáveis cadastrados no módulo Gestão Patrimonial e conter vários vínculos no cadastro dos patrimônios.

Solução
Não é possível marcar o parâmetro: "Usar funcionários RM Labore como responsáveis", que se encontra no menu: Ambiente | Parâmetros | Gestão Patrimonial | Cadastro de Bens | Responsáveis, devido a empresa já conter vários responsáveis cadastrados na visão de cadastro de Responsável do módulo Gestão Patrimonial, e por já conter vários patrimônios com a informação da tabela de responsável já informado nos patrimônios na aba Dados Adicionais.

Importante
O parâmetro acima deverá ser marcado quando a empresa estiver iniciando sua parametrização no módulo Gestão Patrimonial.
Ao optar por usar funcionários do RM Labore como responsáveis, a janela passará a ter uma única função que é a de visualizar os registros, não permitindo qualquer alteração de dados ou inclusão manual de cadastros.
Após vincular algum Responsável (funcionário) em um cadastro de patrimônio, a flag ficará desabilitada para desmarcar.
Ao cadastrar um Responsável diretamente pelo RM Bonum, a flag ficará desabilitada para marcar.

Saiba mais
Para mais informações acesse Responsável.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _