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Ocorrência
Ao acessar o sistema é apresentado o erro:
Não é possível salvar novos arquivos de critical log.
Quantidade Máxima de arquivos atingida: 1000. Isso pode acontecer devido a falta de permissão nas tabelas GCRITICALLOG e GCRITICALLOGDADO
Ambiente
Framework - Linha RM - Frame - Todas as versões do sistema RM
Causa
Esse incidente ocorre, pois falta permissão nas tabelas de armazenamento de logs do sistema.
Solução
Para corrigir a inconsistência, siga os passos abaixo:
- Delete o conteúdo da pasta CriticalErrors: C:\TOTVS\CorporeRM\RM.Net\CriticalErrors - Caso a instalação seja N camadas, a pasta está disponível no servidores que possuem serviço de host, caso a instalação seja local, será necessário apagar os arquivos em cada máquina.
- Os passos abaixo devem ser executados pelo DBA da empresa.
O usuário do Alias (por padrão, sysdba) deve possuir permissão na tabela, para isso siga os passos abaixo:- Acesse o Banco de Dados;
- Copie e cole no Banco de Dados os Comandos à seguir:
GRANT INSERT,DELETE, SELECT, UPDATE ON GCRITICALLOG TO SYSDBA
GO
GRANT INSERT,DELETE, SELECT, UPDATE ON GCRITICALLOGDADO TO SYSDBA
GO
Importante
O comando GRANT concede privilégios específicos para um objeto (tabela, visão, sequência, banco de dados, função, esquema ou espaço de tabelas) para um ou mais usuários ou grupos de usuários. Estes privilégios são adicionados aos já concedidos, se existirem.
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