Ocorrência
Ao utilizar a rotina 1097 é apresentada a mensagem: Fornecedor com o código da cidade inválido ou não informado.
Ambiente
WinThor - Fiscal - Aplicável a partir da versão 29
Causa
Esse incidente ocorre devido à uma inconsistência referente ao código da cidade.
Solução
Para resolver essa mensagem, siga os passos abaixo:
1. Verifique o código do fornecedor da nota indicada, pela rotina 1097 - Geração Arquivo Livro Fiscal Eletrônico, que pode ser identificado expandindo as informações da solução listada abaixo da mensagem do erro;
2. Anote o número da nota apresentado na coluna Núm. Nota da planilha inferior, tela exibida ao clicar o botão Ajuste Apuração ICMS, opção Geração do arquivo SPED Fiscal na tela inicial;
3. Acesse a rotina 1007 - Manutenção de nota fiscal de entrada e localize a nota apontada pela 1097;
4. Clique o botão Editar Emitente, verifique o campo Código Emitente e anote o código do fornecedor;

5. Acesse a rotina 202 - Cadastrar Fornecedor e clique Manutenção de registro;
6. Preencha os filtros conforme necessidade e clique o botão Pesquisar;
7. Na tela de manutenção de registro, caixa 02 - Dados do Fornecedor, campo Cidade IBGE informe o código da cidade do fornecedor (previamente cadastrado na rotina 577 - Cadastrar cidade/cod. IBGE, conforme tabela de IBGE da Receita Federal);
8. Acesse a rotina 1000 - Processamentos Fiscais e informe a Filial;
9. Selecione a aba Opções Acessórias, caixa Geração do Histórico, informe o mês em que está sendo gerado o livro eletrônico e marque a opção Histórico de Movimentações;

10. Preencha o campo Cliente/Fornecedor (opcional) e clique o botão Executar.

Importante
Quando for apresentada a seguinte mensagem de alerta Gerar histórico somente para registros não processados anteriormente?, clique Não.
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