FAQs - Suporte técnico

RH - Linha Protheus - RSP - Exclusão de Vagas gera log - A chave a ser excluída está sendo utilizada

Ocorrência
No módulo Recrutamento e Seleção de Pessoal, ao tentar excluir uma vaga, gera log de ocorrência: 

mceclip0.png

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Recrutamento e Seleção de Pessoal - Todas as versões

Causa
Esse incidente ocorre, pois existe relacionamentos entre a tabela de Vagas (SQS), com a tabela de Currículos (SQG), ou com a Agenda do Candidato, relacionado a Vaga tabela (SQD).

Solução
Para solucionar essa ocorrência, deverá acessar o Módulo 20 (SIGARSP), no seguinte caminho: Atualizações > Cadastro > Vagas, selecionar a vaga que deseja excluir e selecionar  outras ações > excluir.
mceclip6.png

O sistema apesentará a seguinte mensagem de log , deverá clicar em SIM.
mceclip1.png

Será apresentado a mensagem de geração de LOG clique em SIM para o sistema detalhar as possíveis amarrações com a vaga deverá ser desfeita para que possa ser excluído seu cadastro.
mceclip2.png

mceclip3.png

Com a geração do LOG será apresentado maiores detalhes sobre o vinculo desta vaga. Cabe a empresa decidir se irá retirar todos os vínculos para conseguir realizar a exclusão.

mceclip4.png

Se optar pela exclusão acesse o seguinte caminho: Atualizações > Candidato > Agenda, selecione a vaga em questão e exclua sua agenda.
mceclip5.png

Selecione a opção Outras Ações> Consulta por Vaga> Selecione a vaga em questão. 
mceclip7.png

Será apresentado os processos amarrados a vaga, delete a linha e clique em salvar.
mceclip8.png

Após este processo realize a exclusão da vaga, o sistema irá realizar a verificação dos dados e se não houver nenhuma amarrações, será possível realizar sua exclusão.

mceclip9.png


Poderá ser apresentado a mensagem abaixo na tentativa de exclusão.

mceclip10.png

Deverá ser verificado no seguinte caminho: Atualizações > Candidato > Currículo.

mceclip11.png

Selecione o Currículo clique na opção Alterar, retire e informação de COD VAGA conforme campo em destaque. Salve o registro.
mceclip12.png

Execute novamente a tentativa de exclusão da vaga para o sistema avaliar se existe algum outro vinculo. Caso não encontre será apresentado o cadastro da vaga com a opção excluir e basta confirmar o registro.
mceclip13.png

Saiba Mais
Para saber mais consulte os links abaixo:
Central de Artigos Recrutamento e Seleção

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _