Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

WINT - 300 - Mensagem: ORA-00904 NUMVERBA invalid identifier

time.pngTempo aproximado para leitura: 00:02:00 min

 

Ocorrência
Ao executar a rotina 300 - Atualizar Funções de Vendas é apresentado a mensagem: 

ORA-24344: success with compilation error
9621/22 PL/SQL: ORA-00904: "NUMVERBA": invalid identifier
9617/11 PL/SQL: SQL Statement ignored

 

Ambiente
TOTVS Distribuição Linha Winthor - 3 - Vendas -  A partir da versão 30

 

Causa
A rotina 560 - Atualizar Banco de Dados não foi executada, e está faltando campos em algumas tabelas

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Atualize a rotina 560 para a última versão disponível. 

2. Após atualização, abra a rotina 560 e selecione as seguintes tabelas: 

• PCAUTORI

mceclip0.png
• PCDESCONTO

mceclip1.png

• PCDESCONTOC

mceclip2.png

• PCBRINDEEX

mceclip3.png

• PCPRECOPROM

mceclip4.png

• PCPRECOCESTAC

mceclip5.png

3. Ao finalizar, acesse a rotina 300 novamente, e execute o processamento.

 

Importante
Se após realizar o procedimento, a mensagem continuar sendo exibida, acesse a rotina 560 e marque a opção Reprocessar Atualizações da aba Controle de Atualizações e selecione as tabelas novamente conforme informado no passo 2 e reprocesse. 

mceclip0.png

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _