Base de Conhecimento

RH - Linha Datasul - Provisão, Contabilização e Rateios - Mensagem: O centro de custo não pode ser utilizado com a unidade de negócio informada – Integração HCM TOTVS 11 X EMS5 TOTVS 11

mceclip0.png Tempo aproximado para leitura: 00:05:45 min

Ocorrência
Mensagem: O centro de custo não pode ser utilizado com a Unidade de Negócio informada – Integração HCM TOTVS 11 X EMS5 TOTVS 11.

Ambiente
TOTVS RH - TOTVS RH (Linha Datasul) - Provisão, Contabilização e Rateios – Versão 12

Causa
Quando é apresentada a mensagem: O centro de custo não pode ser utilizado com a Unidade de Negócio informada na integração contábil ou Unidade de Negócio não está relacionada ao Estabelecimento! na integração de Títulos do HCM com o EMS, sendo que o HCM e o EMS estão na versão TOTVS 11.

Solução
É necessário que sejam verificadas as seguintes informações:

- Caso a empresa utilize unidade de negócio no HCM, faça a integração do HCM com o extrato de versões ativado, confira a primeira tabela de informações geradas no extrato, verifique se nesta tabela está sendo enviado o código da unidade de negócio do HCM; ou com o log de execução na pasta Impressão do programa de HCM, no Campo Imprimir Log Execução colar o log no Excel, Texto para Colunas > Delimitador > Ponto e Vírgula, verifique se está sendo enviado o código da unidade de negócio do HCM na coluna UnidNegoc.

Exemplo tabela gerada no Extrato de Versões:

Emp  Refer           Seq      Conta EMS  Sub-Conta EMS  Reduzida  Trans EMS  Hist Conta Cont Part EMS  Sub-Conta Con Part EMS  Reduzida Par  Val FASB Data Cotação Val CMCAC  Val Presente  Controle Conta Contáb Contra Partida Estab  Unid Negoc

------ ------------- --------- -------------- ------------------ ------------- ------------ ----- ------------------------- ------------------------------ ---------------- ------------- --------------- ---------------- --------------- ---------- ---------------------------------- -------- -------------

1        MFP01131         1     11305030              0             2           0                                                                          0              0,0000                           0,0000              34.473,84                                                                             001    99

1        MFP01131         2     11305030              0             2           0                                                                          0              0,0000                           0,0000               6.742,77                                                                              001    99

1        MFP01131         3     11305030              0             2           0                                                                          0              0,0000                           0,0000              17.604,59                                                                             001    99

1        MFP01131         4     21123050              0             2           0                                                                          0              0,0000                           0,0000              18.001,07                                                                             001    99

1        MFP01131         5     21123050              0             1           0                                                                          0              0,0000                           0,0000              31.131,45                                                                             001    99

1        MFP01131         6     21123050              0             2           0                                                                          0              0,0000                           0,0000              31.974,43                                                                             001    99


Uma forma rápida de encontrar a linha da tabela que está causando a mensagem é procurar a informação pelo valor, ou seja, no log da integração que mostra a mensagem, é demonstrado o valor do movimento, procure por este valor na tabela gerada no extrato de versões.

- Caso a empresa não utilize Unidade de Negócio no HCM, ou seja, sua matriz de tradução está parametrizada por composição. Exemplo: Unidade de negócio está embutida dentro do Centro de Custo, será necessário que utilizem o conceito de Unidade de Negócio no HCM.

Este processo passou a ser obrigatório após a unificação de conceitos. A partir da unificação, o Sistema não utiliza mais a matriz de tradução do EMS na integração do HCM. Por este motivo, o Sistema não identifica que a unidade de negócio está embutida no código do Centro de Custo, por exemplo, causando a mensagem de inconsistência. Para solucionar esta situação, é necessário que o HCM também utilize o conceito de Unidade de Negócio, fazendo com que na integração, o HCM envie a unidade de negócio separada do código de centro de custo - utilizando o exemplo do centro de custo acima.

Lembrando que todos os exemplos citados neste documento são meramente ilustrativos, o qual pode variar de acordo com a necessidade de cada cliente.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _