FAQs - Suporte técnico

MP-NFE- Rejeição 214: Tamanho da mensagem excedeu o limite estabelecido

Ocorrência
Rejeição 214: Tamanho da mensagem excedeu o limite estabelecido

Ambiente
Microsiga Protheus - a partir da versão 11.80

Causa
Segundo o Manual de Orientação ao Contribuinte, a mensagem enviada aos WebServices para autorização não deve ultrapassar o tamanho de 500 KB. Caso seja encaminhado a Sefaz uma NF-e ou Lote de NF-e que possua um tamanho superior a 500 KB, a mensagem será descartado e retornado a rejeição "214 - Tamanho da mensagem excedeu o limite estabelecido".

Solução

Separar a nota em 2 ou mais notas, pois não a SEFAZ não aceita XML maior que 500 kb.

Por padrão o ERP limita o tamanho do XML em 400k para ter uma margem de de segurança e a nota não for rejeitada.

Porém existe o parâmetro  MV_XMLSIZE e o mesmo faz um tratamento pra diminuir ou aumentar o tamanho do XML para aqueles casos que estão maior  ou menor que 500k.

Este parâmetro deve ser preenchido com numero em milhar

Ex: 500000.

Caso o XML seja maior que 500kb é preciso refazer a nota com uma quantidade menor. Lembrando que isso não é uma limitação do ERP e sim da sefaz.

Só é possível verificar o tamanho do XML no momento da transmissão da nota.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Artigo fechado para comentários.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _