Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Protheus - TOTVS News não sendo exibido

OCORRÊNCIA
Ao acessar o menu de um ou mais módulos do Protheus, o TOTVS News referente ao mesmo não é exibido.

AMBIENTE
Protheus – Framework – A partir da versão 12.1.17

CAUSA
As páginas do TOTVS News podem não ser exibidas devido a cinco cenários diferentes:

  1. Bloqueio de firewall
  2. LIB desatualizada e/ou Application Server desatualizado
  3. Parâmetro MV_PAISLOC com conteúdo inválido
  4. Página inexistente para o módulo
  5. Conteúdo da SYS_APP_PARAM divergente do novo padrão


SOLUÇÃO
Segue abaixo a solução para cada um dos cinco cenários acima citados:

  1. Bloqueio de firewall
    • Verifique por meio do navegador padrão se a URL http://redirect.engpro.totvs.com.br/protheus[MOD_NAME][COUNTRY] sendo aberta corretamente;
    • Para MOD_NAME, insira o nome do módulo removendo o SIGA (ex: quando SIGACOM, utilize COM. Quando SIGALOJA, use LOJA);
    • Para COUNTRY, informe o valor referente ao pais corrente (ex: quando Brasil, utilize BRA)
    • Exemplo de URL: http://redirect.engpro.totvs.com.br/protheuslojabra;
    • Caso a URL não seja exibida corretamente ou o erro 404 (Not found) não ocorra, solicite ao responsável pela infraestrutura do servidor que contém o Application Server, a liberação da URL citada.

  2. LIB desatualizada e/ou Application Server desatualizado
    • Acesse o Portal de Downloads (https://suporte.totvs.com/portal/p/10098/download) e realize o download do último Application Server e LIB disponíveis;
    • Após isto, efetue a atualização do RPO com a LIB e a atualização do binário do Application Server.

  3. Parâmetro MV_PAISLOC com conteúdo inválido
    • O parâmetro MV_PAISLOC é utilizado para realizar a montagem das URLs para exibição do TOTVS News, assim sendo, o mesmo deve estar conforme exemplo abaixo:
      mceclip0.png
    • Caso em sua empresa o arquivo SX6 não seja compartilhado (X6_FILIAL diferente de vazio), verifique por meio da ferramenta APSDU todos os parâmetros MV_PAISLOC para validar se todas estão com o conteúdo correto.

  4. Página inexistente para o módulo
    • Como citado o item 1, é possível que alguns módulos ainda não tenham TOTVS News disponível;
    • Isto posto, acessa a URL http://redirect.engpro.totvs.com.br/protheus[MOD_NAME][COUNTRY] para verificar se há página disponível;
    • Caso seja retornado o erro 404 (Not found), ainda não há TOTVS News para o módulo (vide abaixo):
      mceclip0.png
Esse artigo foi útil?
Usuários que acharam isso útil: 2 de 2

0 Comentários

Artigo fechado para comentários.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _