Ocorrência
Verificar se os registros importados do Protheus para o TAF foram corretamente integrados.
Ambiente
TAF – Nova Gia - A partir da versão 12.1.17
Causa
Necessidade das configurações para a geração do arquivo da Nova GIA através do TAF.
Solução
Verifique o Gerenciador de Integração: TAF -> Miscelânea -> Integração -> Gerenciador de Integração (TAFTICKET):
Nos campos Data De e Data Até informe a data em que o processamento foi executado (TAFAINTEG) e não o período em que a obrigação fiscal está sendo gerada. O filtro deve ser Fiscal.
Neste tela, são apresentados os registros gerados como tickets. Essa rotina identifica o que subiu para o TAF corretamente, o seu ticket consiste em 3 formas:
Legenda verde - Registros Inclusos com sucesso;
Legenda amarela - Registros Alterados (podendo haver registros com inconsistências);
Legenda vermelha - Registros Inconsistentes.
OBS: Caso tenha sido feita várias integrações no mesmo dia, são apresentados tickets diferentes para cada data e hora da execução do processamento.
Clique na linha selecionada, assim abrirá uma tela indicando os layouts que foram integrados e os que não foram integrados:
Clique duas vezes no item com a legenda vermelha, por exemplo, assim visualizará o motivo da inconsistência, conforme exemplo abaixo:
Segue abaixo as documentações dos erros mais comuns e como corrigi-los. Caso o Gerenciador de Integração apresente algum erro que não esteja listado abaixo ou que persista após correção, abra uma solicitação para o Suporte da Totvs e envie um print do erro e o procedimento que foi efetuado.
Erros de Cadastro:
Erros no movimento: (lembrando que se houver erros na Integração do Cadastro e o cadastro não existir no TAF, automaticamente, os movimentos também ocorrerão erros na integração, desta maneira corrija o erro do cadastro e reintegre os movimentos)
0 Comentários