FAQs - Suporte técnico

MP - OFI - Consulta padrão do campo Cod. Serv. ( VO4_CODSER ) com lentidão.



Ocorrência
No módulo Oficina, na rotina de Requisição de Serviço OFIOM030, ao clicar F3 consulta padrão do campo Cod Serviço VO4_CODSER o sistema apresenta uma lentidão muito grande, como ajustar isso?


Ambiente
Protheus – Oficina – A partir da versão 12.1.07


Causa
Como funciona o filtro do F3.
Para cada linha da tabela é aplicada a leitura do registro e efetuada a checagem do filtro, ocasionando a lentidão devido a quantidade de registros que foram acrescentados a tabela ( Quase 13 mil registros )


Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. A consulta do F4 foi criada justamente para resolver esse tal problema que o F3 proporciona. Desta forma a solução é utilizar a consulta do F4 para ter mais agilidade;

2. Caso queria utilizar o F3, deve retirar o filtro da mesma, excluindo a linha com tipo 6 da tabela SXB. Porém desta forma nenhum filtro é aplicado e todos os registros da tabela de serviços serão apresentados.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _