Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAFAT - ERRO MATR600 - Invalid Field Order in Query - Memo fields must be grouped at the end of the Query

Cross Segmento - TOTVS Backoffice (Linha Protheus) - SIGAFAT - ERRO MATR600 - Invalid Field Order in Query - Memo fields must be grouped at the end of the Query

time.pngTempo aproximado para leitura: 00:04:00 min

Ocorrência
Ao tentar gerar o relatório MATR600, ocorre o erro;

TOP Error -19 - Invalid Field Order in Query -- Memo fields must be grouped at the end of the Query. ( From tODBCStatement::BindCols )
Thread ID [43716] User [ana] IO [383] Tables [17] MaxTables [17] Comment [MATR600 - TCPIP - ThreadID(93768)] SP [ ] Traced [No] SQLReplay [No] InTran [No] DBEnv [MSSQL/CMTTWK] DBThread [(SPID 369,634)] Started [16/08/2019 16:38:01] IP [127.0.0.1:12871] IDLE [ ] InTransact [ ] Memory [369464] Running [ROP_QUERY] RCV [11005] SND [30733] TCBuild [20180606-20181019] TCVersion [18.1.1.4] ARCH [64] OS [WINDOWS] BUILD [RELEASE]
on __EXECSQL(APLIB300.PRW) 10/04/2019 14:27:47 line : 149


Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - FAT - a partir da release 12.1.17

Causa
O erro ocorre ao acionar a opção de impressão do cadastro onde ,o cadastro que possui algum campo memo, gerando error.log em ambientes com dicionário no banco de dados.


Solução
Para solucionar essa ocorrência, realize os seguintes passos:

 

1. Efetue download da última LIB disponível no portal para o seu ambiente:

Ambiente 32 Português

Ambiente Lobo Português

e aplique ao RPO do ambiente via TDS - Totvs developer Studio ou o antigo IDE.

Obs: Lembrando que para 12.1.17 e anteriores, o pacote de lib é sempre nomeado como: LIB_P12 - TOPCONNECT - 32 
E para as releases da 12.1.23 em diante, a lib é nomeada como: LIB_P12 - TOPCONNECT - Lobo.

 

2. Efetue download do último Dbacess conforme o seu ambiente, e faça atualização do mesmo:  Downloads e Atualizações Dbaccess

 

3. Reinicie o smartclient e refaça o processo.

Obs: O processo informado acima para ser realizado requer um analista com conhecimentos em estrutura de Protheus. Qualquer dúvida no processo, acione a equipe de Framework.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _