Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Protheus - Directory (\Spool\*.rel) exceeded 10000 files

[Remover as instruções entre colchetes]

Ocorrência
Ao analisar console.log do appserver é exibida a mensagem no log directory (\Spool\*.rel) exceeded 10000 files.
Ambiente
MP – Configurador – A partir da versão 11.8

Causa
Conforme documentação abaixo :

https://tdn.totvs.com/display/tec/Directory 

A função Directory tem uma limitação de apresentar apenas os primeiros 10.000 arquivos, sendo qualquer excedente ignorado.

Portanto qualquer pasta do sistema que contenha mais de 10.000 arquivos causara uma falha onde o sistema não conseguirá exibir todos os arquivos, no caso da pasta spool onde o sistema armazena arquivos de relatórios impressos (*.rel, *.html, *.xml etc.) estes podem ser excluídos pois tratam-se de arquivos temporários do sistema.

Para exclusão dos arquivos não é necessário parar os serviços do ambiente e pode ser realizado com outros usuários utilizando o sistema.

O intuito destes arquivos é serem utilizados em todas as rotinas do sistema no menu miscelâncea -> Spoll, onde será possível imprimir novamente qualquer relatório que já tenha sido impresso anteriormente


Solução
Executar a limpeza da pasta exibida no erro, deixando a mesma com uma quantidade menor do que 10.000 arquivos.

Artigos relacionados:

https://tdn.totvs.com/display/tec/Directory 

https://tdn.totvs.com/pages/releaseview.action?pageId=224455444

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _