FAQs - Suporte técnico

MP-TEC - array out of bounds ( 0 of 16 ) on AT450F4LOK(TECA450.PRX)

Ocorrência

Ao efetuar a edição da ordem de serviço através da tecla F4 o sistema está apresentando error.log:

array out of bounds ( 0 of 16 ) on AT450F4LOK(TECA450.PRX) 21/06/2019 18:27:51 line : 2194

Ambiente

Microsiga Protheus -  a partir da release 12.1.17.

Causa

O erro de array ocorre quando algum campo chamado no array não existe no banco/dicionário de dados, não está marcado como usado ou teve o seu nível de campo alterado.

Neste caso, houve alteração no array,se fazendo necessário a atualização da rotina teca450.

Solução

Para solucionar essa ocorrência, realize os seguintes passos:
1. Efetuar o download do pacote teca450 de acordo com o seu release de ambiente: 12.1.25:https://suporte.totvs.com/portal/p/10098/download?e=767107 ; 12.1.23:https://suporte.totvs.com/portal/p/10098/download?e=767106 ; 12.1.17:https://suporte.totvs.com/portal/p/10098/download?e=767105 ;
2. Aplicar o pacote ao RPO via TDS - Totvs Developer Studio.
3. Reiniciar o Smartclient e efetuar o processo novamente.

OBS: O processo informado acima para ser realizado requer um analista com conhecimentos em estrutura de Protheus. Qualquer dúvida no processo, acione a equipe de Framework.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _