FAQs - Suporte técnico

MP - SIGACOM - Error.log - SetOrder - Index not found. on AF012SN2(ATFA012.PRW) 10/01/2019 17:00:11 line : 12826

Ocorrência
Ao incluir um Documento de Entrada com TES parametrizada para gerar Ativo Imobilizado = Sim, é gerada a mensagem / erro abaixo:

Error.log
SN2xx0: SetOrder - Index not found. on AF012SN2(ATFA012.PRW) 10/01/2019 17:00:11 line : 12826

 


Ambiente
Protheus - Compras - 12.1.17

Causa
Esse incidente ocorre, quando é incluído um Documento de Entrada com a TES parametrizada para gerar Ativo Imobilizado = Sim.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

Por gentileza, verifique se atualmente a sua tabela SN2 só tem o indice ordem 1.
N2_FILIAL+N2_CBASE+N2_ITEM+N2_TIPO+N2_SEQUENC

Caso afirmativo:
Por favor, via configurador, crie este índice com a ordem = 2 na tabela SN2, conforme abaixo:
N2_FILIAL+N2_CBASE+N2_ITEM+N2_TIPO+N2_SEQ

https://centraldeatendimento.totvs.com/hc/pt-br/articles/360019903692-MP-FRAME-Como-criar-%C3%ADndices-no-Protheus

Após criar esse segundo índice, efetue novo teste na rotina.

Efetue o procedimento em ambiente de teste ou homologação para validação.

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