Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - DLL corrompida ou divergente para arquitetura da aplicação smartclient

time.pngTempo aproximado para leitura: 00:03:00 min

Ocorrência
É retornado erro ao utilizar as funções de manipulação de .DLL (ex: ExecInDLLOpen()).

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) – ADVPL – A partir da versão 12.1.23

Causa
Isto ocorre quando o sistema não consegue realizar a troca de informações corretamente, assim sendo gerado o retorno -1.

Solução
Validar se a .DLL corrompida ou divergente para a arquitetura da aplicação (SmartClient).

Exemplo
Em um SmartClient 64 bits (IsRmt64() == .T.) temos uma .DLL (Dynamic-Link Library) que retorna o código -1 em um remote x64, porém retorna 1 em remote x86.
Com base neste cenário, executaremos o comando FILE (presente em ambientes Linux ou aplicações que simulem o ambiente, neste caso, utilizamos o Git Bash) para validar a arquitetura:

$ file MINHA_BIBLIOTECA.dll
MINHA_BIBLIOTECA.dll: PE32 executable (DLL) (GUI) Intel 80386, for MS Windows

Como pode ser visto, esta .DLL foi desenvolvida com base na arquitetura x86 (80386), assim sendo, não será executada com sucesso em um ambiente x64. Desta forma, tornando necessária a recompilação com base na arquitetura x64.

Saiba mais
ExecInDLLOpen

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

1 Comentários

  • Avatar
    RODRIGO VASCONCELOS MOREIRA

    Estou utilizando o DLL na estrutura de 64 bits, porém ele permanece não executando essa função

    0
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _