Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Agro - Linha Protheus - AGR - Array out of bounds on AGRA840NFE AGRUTIL01

time.png Tempo aproximado para leitura: 00:01:10 min

Ocorrência
Ao dar entrada em uma nota fiscal e esta com seguinte erro array out of bounds ( 0 of 38 ) on AGRA840NFE AGRUTIL01


Ambiente
TOTVS Agro - TOTVS Agro - Comercialização (Linha Protheus) - Originação de Grãos (OG) - Versão 12

Causa
O erro de array out of bounds 0 of ... acontece quando algum campo do array não está em uso pelo Sistema ou tem nível superior ao do usuário não estando disponível para o usuário ou quando não está marcado o Módulo ou Todos os Módulos na configuração do campo no Módulo Configurador.


Solução
Avalie os campos abaixo NP9_PRDDES - Desc ProdutoB1_DESC - Descrição do Produto verifique se algum não está em uso ou se estão com nível 1 padrão ou outro nível ou se o Módulo não está marcado ou se falta marcar Todos os Módulos

Não estando marcado como usado, favor marcá-lo como usado e ou alterando o nível via SIGACFGConfigurador e ou marcando todos os módulos, salve as alterações em modo exclusivo e faça uma nova validação, afim de verificar se o error.log foi corrigido.

Importante
Caso os procedimentos não resolvam o problema, faça o seguinte procedimento em modo exclusivo, sem usuários conectados

1. Faça backup das tabelas SB1 - Descrição Genérica do Produto e NP9 - Lotes de Sementes;

2. Drop as tabelas SB1 e NP9;

3. Acesse o Sistema para criação das novas tabelas baseadas no dicionário SX3 - Campos das Tabelas;

4. Volte os backups das tabelas SB1 e NP9;

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _